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Interactive Test IT-02:  Test ProProsper General
Functions

Purpose

The purpose of this test package is to provide instructions and recording materials for each person participating in the interface
testing of Ernst & Young’s ProProsper application for Windows.  This test package is written for all users who have access to the
ProProsper application.

This package will test the interaction of general system functions of the ProProsper application on platforms running the Windows
95 operating system.

General Instructions

Please take the time to look through this test package before beginning the test.  Ensure that it contains all the test scripts mentioned
in the Contents.  Unless the Test Administrator tells you otherwise, follow the test scripts in the order in which they are presented in
this test package.

It is assumed that ProProsper has been installed in accordance with test package ET-01: Test ProProsper Installation.  If
ProProsper has not been installed on the system you will use to perform these tests, do so prior to beginning.
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Generally, these test instructions are written for mouse use.  If your mouse is set for the right hand, click the left mouse button once
to open a menu, to initiate a menu command, to initiate a command button or to initiate an icon button command; double-click (click
twice in rapid succession) on the left mouse button to select an item and to initiate its associated action.  If your mouse is set for the
left hand, click the right mouse button right mouse button once to open a menu, to initiate a menu command, to initiate a command
button, or to initiate an icon button command; double-click on the right mouse button to select an item and to initiate its associated
action.

Sometimes a step will include both mouse and keyboard instructions.  When indicated, several testers should follow mouse
instructions; and several other testers should follow keyboard instructions during these test scripts.

List boxes contain multiple rows of information.  Most list boxes display a highlighted row when you first access them.  This is the
system default.  To accept the system default, simply click on the appropriate command button (usually OK) to initiate the action
you want.  To change the system default, simply click on another row.  From any list box without a default row, you need to click
on a row to select it.  Then, click on the command button you want in order to initiate its associated action.  In all list boxes, you
should be able to double-click on a row to select it and to initiate the default command (usually OK) associated with the window,
tab, or dialog box.  (Default command buttons appear with a heavier black border around them.  Default buttons allow you to
initiate the default command by pressing Enter.)

Conventions

For these test scenarios, you will be instructed to “click” or to “double-click” your mouse.

All menu names, menu commands, and windows controls are identified as such and appear in Arial Bold typeface.

Menu commands appear in the format of “File> Print menu command”, which indicates that this is a command on the File pull-
down menu name.  The instruction reads:  “Click on the File> Print menu command.”  You click once on the File menu.  The
File menu opens.  You click once on the Print command located on the File menu.  The system initiates the action associated with
the Print menu command; in this instance, it opens the Print dialog box.
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By definition, all system-populated fields are required fields.  When you access a window or dialog box for the first time and a text
box contains a value, or a row is highlighted, or an option button is selected, or a check box is selected, that value is the system
default.  You cannot delete a system default; you must either accept the default or change it.

Preparation

Please ensure that you print your name, title, the date you perform the test, and the type of hardware the test was performed on for
each test script or subscript.  (Different evaluators or developers may look at separate pieces of your test scenario and may need to
contact you for additional information.)

Please ensure that the test evaluators can read any comments you make.  (Ball-point pens with blue ink are recommended.)  If you
need additional space for comments, use the back of the page and number the continuing comment with the appropriate step number.
Or, fill out a [name of bug tracking control document].

If you discover a bug, try to reproduce it.  Write down the steps you took that will let us reproduce the condition under which the
bug occurred.  If you consider a feature to be overly complicated or if you think of enhancements that would benefit the end users in
performing tasks associated with Proper 2.0, please provide a detailed account of the problem you encountered or the enhancement
you recommend.  When creating a [name of bug tracking control document] or making any comments concerning the ProProsper
application, please provide the name of the associated window or dialog box, menu, etc.

What’s In This Package

[Name of bug tracking control document]   for recording observations about the system in addition to any information you may
provide in the Comments column.  If you need to provide a [name of bug tracking control document], we suggest that you indicate
so in the Comments column for the particular step associated with the[ name of bug tracking control document].

Testing scripts and subscripts  a sequence of instructions and expected responses for this test scenario.  Each step in a script or
subscript has an associated column for you to mark a status of either pass or fail and for you to provide additional comments, as
necessary.  Please test each script or subscript in the order defined in the remainder of this document.
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Importing and Exporting Data

Step User Action Expected Response P F Comments

1. Copy the file TESTER.QIF to the DATA
directory under the directory in which
Proper is installed.

2. From the Menu Bar, select the File menu. The File menu appears.

3. Select the Import… menu item under the
File menu.

The Open dialog box appears.

The File name field defaults to *.QIF.

4. Click on the file TESTER.QIF.

5. Click the OK button. Still cannot successfully import
QIF files from Quicken.  Get error
on input dialog box.  Dialog then
appears indicating that data has
been imported.  No data appears
in ProProsper however.

6. 

7. 

8. 

9. Click the OK button. The Import From dialog box closes and the
Import From QIF File dialog box appears.

10. Click the Select .QIF Files button. The Open dialog box appears.

11. Ensure that the File Name: field reads
*.qif.

12. Click the Cancel button. The Open dialog closes.
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Step User Action Expected Response P F Comments

13. Click the Cancel button on the Import From
QIF File dialog box.

The Import From QIF File dialog box
closes.

14. 

15. 

16. 

17. 

18. From the Menu Bar, select the File menu. The File menu appears.

19. Select the Export… menu item under the
File menu.

The Export dialog box appears.

20. Ensure that the Portfolio Security Prices
radio button is selected.

21. Click the OK button. The Export dialog box closes and the Save
As dialog box appears.

22. Enter QUOTES1 in the File name field.

23. Click the Save button. An Information message box will appear
indicating that the information has been
successfully exported to the file.

24. Click the OK button. You are returned to the ProProsper
application desktop.

25. From the Menu Bar, select the File menu. The File menu appears.

26. Select the Export… menu item under the
File menu.

The Export dialog box appears.

27. Click the Turbo Tax (TXF) radio button so
that it is selected.

The Portfolio Security Prices radio button
is deselected



Importing and Exporting Data

ProProsper Interface Test Plan   ••   proprosper_it_02.doc Interactive Test IT-02:  Test ProProsper General Functions  ••  7

Step User Action Expected Response P F Comments

28. Click the OK button. A Tax Report Date Range dialog box
appears.

29. Click the From: pull-down. The Start date pull-down opens revealing a
calendar.

30. Use the month pull-down to select the
month January.

31. Use the year spin box to select the year
1996.

32. Click on the 1st date (Monday the 1st). The Start date pull-down closes and
indicates the date of 01/01/1996.

33. Click the To: pull-down. The Start date pull-down opens revealing a
calendar.

34. Use the month pull-down to select the
month December.

35. Use the year spin box to select the year
1996.

36. Click on the 31st date (Tuesday the 31st). The Start date pull-down closes and
indicates the date of 12/31/1996.

37. Click the OK button. A Save As dialog box appears.

38. Enter TTAX in the File name field.

39. Click the Save button. An Information message box will appear
indicating that the information has been
successfully exported to the file.

40. Click the OK button. You are returned to the ProProsper
application desktop.



Importing and Exporting Data

ProProsper Interface Test Plan   ••   proprosper_it_02.doc Interactive Test IT-02:  Test ProProsper General Functions  ••  8

Step User Action Expected Response P F Comments

41. Launch WordPad using
Start>Programs>Accessories>WordPad.

42. In WordPad, click the File menu. The File menu opens.

43. Select the Open… menu item. The Open dialog box appears.

44. Locate the directory C:\INSTALL1 using the
Look in: field.

45. Select All Documents (*.*) in the Files of
type: pull-down.

46. Double-click on the file quotes1.txt. The file opens.  You can see any quotes
information from the export within this file.

47. In WordPad, click the File menu. The File menu opens.

48. Select the Open… menu item. The Open dialog box appears.

49. Locate the directory C:\INSTALL1 using the
Look in: field.

50. Select All Documents (*.*) in the Files of
type: pull-down.

51. Double-click on the file TTAX.txf. The file opens.  You can see any quotes
information from the export within this file.

52. Double-click on the control menu of
WordPad.

WordPad closes.
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Print Preview, and Print Setup

Step User Action Expected Response P F Comments

1. From the Menu Bar, select the File menu. The File menu appears.

2. Select the Open… menu item under the
File menu.

The Open dialog box appears.

3. Select the file TESTONE.PTX from the File
name: list box.

4. Click the Open button. The plan opens.

The ProProsper Navigator is displayed.

5. From the Menu Bar, select the Tools
menu.

The Tools menu appears.

6. Select the Income Tax Estimator menu
item from the Tools menu.

The Income Tax Estimator form opens.

7. From the Menu Bar, select the File menu. The File menu appears.

8. Select the Print Preview menu item under
the File menu.

The print preview form appears showing a
page with some information on it.

9. Move your cursor over the displayed page. The cursor takes the shape of a magnifying
glass.

10. Click the right mouse button once. A zoom occurs so that the page appears
closer.

11. Click the right mouse button again. A zoom occurs so that the page appears
closer.

The mouse cursor returns to its standard
cursor shape.
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Step User Action Expected Response P F Comments

12. Click the right mouse button once. A zoom out occurs so that the page
appears as it did in step 12.

13. Click the Zoom In button. A zoom occurs so that the page appears
closer.

14. Click the Zoom In button. A zoom occurs so that the page appears
closer.

15. Click the Zoom Out button. A zoom out occurs so that the page
appears as it did in step 12.

16. Click the Next Page button. The second page of the material to be
printed is displayed.

17. Click the Prev Page button. The first page of the material to be printed
is displayed.

18. Click the Two Page button. Both pages of material to be printed are
displayed side by side.

The Two Page button becomes a One
Page button.

19. Click the One Page button. One page of material to be printed is now
displayed.

The One Page button becomes a Two
Page button.

20. Click the Print… button. The Print dialog box appears.

21. Click the OK button. The file prints to the local printer.

If the file does not print to the local printer,
consult your system administrator to
determine the cause of the print failure.
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Step User Action Expected Response P F Comments

22. Inspect the printed document to ensure that
it appears properly formatted.  (Do not
inspect for data integrity.)

It is unnecessary to test any other aspect of
the Print dialog since it is related to the
printer drivers associated with the specific
printer and Windows 95.

23. From the Menu Bar, select the File menu. The File menu appears.

24. Select the Print Preview menu item under
the File menu.

The print preview form appears showing a
page with some information on it.

25. Click the Close button. The Print Preview form closes.

26. Select the Print Setup… menu item under
the File menu.

The Print Setup dialog box for the default
printer attached to your system appears.

27. Click the Cancel button.

It is unnecessary to test any other aspect of
the Print Setup dialog since it is related to
the printer drivers associated with the
specific printer and Windows 95.

The Print Setup dialog box closes.

28. Double-click on the control menu to close
the Income Tax Estimator form.

The Income Tax Estimator form closes.
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Printing Data

The following test procedure should be performed for each form which contains printable data.  Use the first table show below
(Forms to Test) to determine all forms to test.  Perform the test procedure from the second table (Form Print Test) to test each
form.  When you have tested the form, check the P or F column of the first table (Forms to Test) as applicable.
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Forms to Test

Step User Action Expected Response P F Comments

1. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

2. Click on the Balance Sheet menu item. The Financial Plan Summary form opens.

3. Test form in accordance with the Form
Print Test table which follows this table.

4. From the form, double-click on the Control-
menu box.

The Financial Plan Summary form closes.

5. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

6. Click on the Budget menu item.  (If
nothing happens here do the following:

a.  Perform steps 1 and 2

b.  Click the Budget panel so that the
Budget panel is displayed.

The Balance Sheet & Budget form opens.

7. Test form in accordance with the Form
Print Test table which follows this table.

8. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

9. Click on the Goals menu item. The Goals form opens.

10. Test form in accordance with the Form
Print Test table which follows this table.
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Step User Action Expected Response P F Comments

11. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

12. Click on the Calculator menu item. The Calculator opens.  There is no need to
test the menu functions of the Calculator
since it is a Windows 95 native tool.

13. From the calculator window, double-click
on the Control-menu box.

The Calculator closes.

14. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

15. Click on the 401(k) Plan menu command. The 401(k) form opens.

16. Test form in accordance with the Form
Print Test table which follows this table.

17. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

18. Click on the 403(b) Plan menu command. A dialog appears which cannot be printed.

19. Click the OK button. The dialog closes.

20. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

21. Click on the Buy vs. Rent A Home menu
command.

The Buy vs. Rent A Home form opens.

22. Test form in accordance with the Form
Print Test table which follows this table.

23. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

24. Click on the Disability menu command. The Disability form opens.
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Step User Action Expected Response P F Comments

25. Test form in accordance with the Form
Print Test table which follows this table.

26. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

27. Click on the Estate Tax menu command. The Estate form opens.

28. Test form in accordance with the Form
Print Test table which follows this table.

29. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

30. Click on the Income Tax Estimator menu
command.

The Income Tax Estimator form opens.

31. Test form in accordance with the Form
Print Test table which follows this table.

32. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

33. Click on the Lease vs. Buy a Car menu
command.

The Lease vs. Buy a Car form opens.

34. Test form in accordance with the Form
Print Test table which follows this table.

35. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

36. Click on the Life Insurance menu
command.

The Life Insurance form opens.

37. Test form in accordance with the Form
Print Test table which follows this table.
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Step User Action Expected Response P F Comments

38. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

39. Click on the Loan menu command. The Loan Calculator form opens.

40. Test form in accordance with the Form
Print Test table which follows this table.

41. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

42. Click on the Pension menu command. The Pension form opens.

43. Test form in accordance with the Form
Print Test table which follows this table.

44. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

45. Click on the Refinance menu command. The Refinance form opens.

46. Test form in accordance with the Form
Print Test table which follows this table.

47. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

48. Click on the Taxable vs. Tax Deferred
menu command.

The Taxable (vs) Tax-Deferred form
opens.

49. Test form in accordance with the Form
Print Test table which follows this table.

50. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

51. Click on the Time Value of Money menu
command.

The Time Value Money form opens.
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Step User Action Expected Response P F Comments

52. Test form in accordance with the Form
Print Test table which follows this table.

53. From the Menu Bar, click on the Tools
menu.

The Tools menu opens.

54. Click on the W-4 Exemptions menu
command.

The W-4 Exemptions form opens.

55. Test form in accordance with the Form
Print Test table which follows this table.

56. From the Menu Bar, click on the Portfolio
menu.

The Portfolio menu opens.

57. From the Portfolio menu, click on the
Portfolio Manager menu command.

The Portfolio Manager form opens.

58. Test form in accordance with the Form
Print Test table which follows this table.
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Form Print Test

Step User Action Expected Response P F Comments

1. Open selected form from previous table
(Forms to Test).

Applicable form opens.

2. Select the Print menu item under the File
menu.

The Print dialog box appears.

3. Click the OK button. The file prints to the local printer.

If the file does not print to the local printer,
consult your system administrator to
determine the cause of the print failure.

4. Inspect the printed document to ensure that
it appears properly formatted.  (Do not
inspect for data integrity.)

It is unnecessary to test any other aspect of
the Print dialog since it is related to the
printer drivers associated with the specific
printer and Windows 95.

5. Double-click on the control menu to close
the applicable form.

The form closes.
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Access Help Engine and About Function

Step User Action Expected Response P F Comments

1. From the Menu Bar, click on the Help
menu.

The Help menu opens.

2. Select the Help Topics menu item under
the Help menu.

The on-line help system launches and the
table of contents help for the ProProsper
application is displayed.

3. Double-click on the on-line help window
control menu.

The on-line help system closes.

4. Select the About ProProsper menu item
under the Help menu.

A dialog box appears indicating the current
version of the ProProsper application that
you are running.

5. Click the OK button. The dialog box closes.
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Access Context-Sensitive Help

The following test procedure should be performed for each form and dialog available in ProProsper.  Apart from the installation
routine (which does not contain any on-line help), each form, dialog, and menu contains context-sensitive help which will load when
the F1 key is pressed.  The following table will guide you to each menu item and dialog.  When a step instructs you to “test help,”
do the following:

1.  Press F1.
2.  Ensure that the help which appears relates to the form, dialog, or menu item.
3.  Double-click the help engine control menu to close help.
4.  Press Tab to move to the next field or control.
5.  Repeat steps 1 through 4 until all fields and controls on the form or dialog have been tested.
6.  Move to the next step in the table.

Step User Action Expected Response P F Comments

1. Double-click on the ProProsper application
control menu.

The ProProsper application closes.

2. From the Start Menu, click on the
ProProsper application icon under
Programs> ProProsper Test>.

The ProProsper application window opens.
The ProProsper splash screen occupies the
center of the application window.

3. Click anywhere on the ProProsper
application.

The ProProsper splash screen closes.

The Welcome to ProProsper dialog box
appears.
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Step User Action Expected Response P F Comments

4. Perform the following steps to every form
dialog and control in the ProProsper
application.  In addition, perform these
steps with every possible menu/menu item
activated (i.e., when a menu is open and/or
a menu item is highlighted prior to
activation).  In no instance should an error
message occur.  In no instance should an
invalid or unrelated topic be found.

5. Press the F1 key.

6. Ensure that a help topic which is related to
the currently selected function appears.

7. Close the help engine by double-clicking on
its control menu.

8. Press the Tab key to move to the next
control, field, or item.

9. Return to step 5 until all dialogs and forms
have been tested.

This completes interactive test IT-02.  Proceed to interactive test scenario IT-03 to continue testing the ProProsper application.


